"Passwort vergessen" funktioniert nicht

Kein System ist vollkommen, findet Ihr Fehler im System der Version 3.0, könnt ihr diese hier gerne Posten. Wir werden auch kurzfistige Lösungen und Fixes hier schreiben.

Moderatoren: Magnus, mmaass, ablass

"Passwort vergessen" funktioniert nicht

Beitragvon dragonzoo » Di 16. Mär 2021, 21:22

Die Funktion "Passwort vergessen" führt bei einer tatsächlich vorhandenen Mailadresse zu einem Fehler 500, bei nicht vorhandenen Mailadressen wird angezeigt, dass ein neues Passwort zugesandt wurde.
dragonzoo
 
Beiträge: 2
Registriert: Do 4. Mär 2021, 22:00

Re: "Passwort vergessen" funktioniert nicht

Beitragvon mmaass » Mi 17. Mär 2021, 06:47

Ich kann es nicht komplett nachvollziehen.
Es stimmt, es kommt eine Meldung, auch wenn die Adresse nicht stimmt, dass schauen wir nach.
Bei einer richtigen Adresse bekommen wir jedoch auch die passende Mail.
Wir prüfen das allgemein noch mal.
www.randshop.com
Entwicklung - Anpassung - Support
Benutzeravatar
mmaass
Admin
 
Beiträge: 5168
Registriert: Di 24. Aug 2004, 17:44
Wohnort: Berlin

Re: "Passwort vergessen" funktioniert nicht

Beitragvon quad-th-design » Mi 17. Mär 2021, 07:15

Hallo,

ich habe das eben auch getestet.
Bei mir kommt immer egal ob es eine Fake Mailadresse ist die es gar nicht im Shop gibt oder eine registrierte:

Ein neues Passwort wurde soeben an Ihre E-Mail-Adresse gesendet.


Wenn die Mailadresse registriert ist, kommt auch bei mir ein neues Passwort an.

Meine Version 2.5 mit Update auf 3.0

MfG
quad-th-design
 
Beiträge: 54
Registriert: Do 22. Apr 2010, 16:34

Re: "Passwort vergessen" funktioniert nicht

Beitragvon Werner » Mi 17. Mär 2021, 09:52

Ja auch eben getestet, gleiches Problem:

Passwort vergessen

Ein neues Passwort wurde soeben an Ihre E-Mail-Adresse gesendet. Es kam aber keine E-Mail an.

Ein anderer Versuch endete mit einer leeren weißen Seite und ebenfalls keine mail!
Werner
 
Beiträge: 206
Registriert: Mi 22. Jun 2011, 13:18

Re: "Passwort vergessen" funktioniert nicht

Beitragvon Werner » Mo 5. Apr 2021, 00:08

Hallo,
jetzt kommt bei mir auch bei einer Bestellung keine mail mehr an den shopbetreiber an...., hängt das vielleicht irgendwie zusammen?? Mein maillog zeigt allerdings an, das wohl eine mail versand wurde?!
Werner
 
Beiträge: 206
Registriert: Mi 22. Jun 2011, 13:18

Re: "Passwort vergessen" funktioniert nicht

Beitragvon quad-th-design » Di 6. Apr 2021, 10:38

Ändern Sie doch mal die Betreiber EMailadresse ab und testen alles noch einmal durch, glaube nicht das es Shop liegt, sondern mehr am Betreiber der EMailadressen. Eventuell blockt dieser den Absener oder schickt alle Mails in den Spam. Dieser Fehler ist bei mir nicht vorhanden haben sehr viele Testmails gemacht und alle kamen nach dem Update auf 3.0 an, kann eigentlich nur vom Hoster abhängig sein.

Meine Tests waren alle von 1&1/Ionos Shop Betreiber Mailadresse und Kunden Adresse GMX.de und GMX.net.
quad-th-design
 
Beiträge: 54
Registriert: Do 22. Apr 2010, 16:34

Re: "Passwort vergessen" funktioniert nicht

Beitragvon Werner » Di 6. Apr 2021, 10:59

Hallo,
ja danke für den Hinweis, werde ich mal testen.
Meinen Hoster hab ich schon kontaktiert, wobei man daraus nicht ganz so schlau wird:

Schönen guten Morgen Herr .....,

gerne helfen wir Ihnen weiter. Der Versand Ihres Postfachs und Ihres Webspaces sind nicht mehr gesperrt. Dementsprechend werden E-Mails an den empfangenden Server zugestellt, sofern Sie von unseren Servern keine Antwort erhalten, dass es nicht möglich war.

Dementsprechend müssten wir Sie bitten uns diese Antwort weiterzuleiten oder sich mit dem Anbieter des Postfachs des Shopbetreibers in Verbindung zu setzen.

Sollten Sie noch weitere Fragen haben, stehe ich Ihnen gerne zur Verfügung.


mit dem Anbieter des Postfachs des Shopbetreibers ????????? iCH BIN DOCH DER SHOPBETREIBER UND DAS POSTFACH LIEGT DOCH BEIM HOSTER ?????
Werner
 
Beiträge: 206
Registriert: Mi 22. Jun 2011, 13:18

Re: "Passwort vergessen" funktioniert nicht

Beitragvon quad-th-design » Di 6. Apr 2021, 12:46

Die Mails aus dem Shop werden ja nicht über ein Postfach verschickt, da liegt ein Irrtum vor. Das wird über den PHPMailer durchgeführt sprich über das PHP des Hosters, die Mailadresse des Shopbetreibers wird dabei als Absende Adresse verwendet. Wenn ihr Mail Provider der Empfängeradresse der Mails aber die Mailadresse des Shop Betreibers/Hosters nicht mag können die Mails abgewiesen werden.

Da über die 1&1 Emailserver in der Vergangenheit sehr viel Spam lief, hatten andere Provider 1&1 teilweise auf eine Blacklist gesetzt, somit gehen die Mails aus dem Shop raus kommen aber bei einem Empfänger nie an. Theoretisch sollte man eine undelivery Mail im Postfach der Mailadresse vom Shopbetreiber erhalten aber das passiert eben häufig nicht.

Nur eine Theorie aber das bekommt man eben durch kostenlose Mailadressen anlegen und etwas rumprobieren raus.

Ist die Mailadresse des Shopbetreibers denn der gleiche Hoster wie der vom Webspace wo der Shop liegt, wenn ja würde dieser sich ja nicht slebst blockieren und die Theorie von mir greift nicht.
quad-th-design
 
Beiträge: 54
Registriert: Do 22. Apr 2010, 16:34

Re: "Passwort vergessen" funktioniert nicht

Beitragvon Werner » Di 6. Apr 2021, 14:00

Hallo,
danke für Deine Hilfe.
Ja mailadresse und webspace alles der gleiche hoster. Ich hatte den mailaccount beim hoster für eine Zeit lang sperren lassen wegen zuviel spam, dann wieder aktivieren lassen.
Mails an die E-Mailadresse funktionieren, nur eben die vom shop aus nicht, das maillog sagt aber die mails seien rausgegangen also irgendwie verschickt worden.
Den sapmschutz beim hoster habe ich wieder auf mittel gestellt.
Werner
 
Beiträge: 206
Registriert: Mi 22. Jun 2011, 13:18

Re: "Passwort vergessen" funktioniert nicht

Beitragvon quad-th-design » Di 6. Apr 2021, 18:16

Dann legen sie sich mal eine kostenlose Mailadresse irgendwo bei GMX, WebDE oder wo auch immer an. Die neue Emailadresse im Shopbetreiber hinterlegen und testen ob Mails ankommen. Wenn die ankommen liegt der Rest am Hoster nicht am Shop, gleiches gilt auch für das PW Vergessen.
quad-th-design
 
Beiträge: 54
Registriert: Do 22. Apr 2010, 16:34

Re: "Passwort vergessen" funktioniert nicht

Beitragvon Werner » Do 8. Apr 2021, 09:59

Hallo,
nochmals danke für Deine Tipps.
Der Fehler lag beim hoster, obwohl ich da außer der Sperre an den E-Mails nichts gemacht habe!! Ich habe es neu eingerichtet. Mails vom shop kommen jetzt an. Die Registrierung mit meinem alten PW klappt aber nicht, auch neues PW zusenden nicht.
Eine komplette Neuregistrierung mit neuen Daten funktionierte aber.
Ich habe das patch spamschutz eingespielt, aber ob es daran liegen kann....?
Ich Frage mich dann wie es bei den Kunden ankommt, wenn sie sich nicht mehr einloggen können....?
Grüße
Werner
 
Beiträge: 206
Registriert: Mi 22. Jun 2011, 13:18


Zurück zu Bugmeldungen

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast