Keine E-mails bei Bestellung

Alle Fragen und Probleme zur aktuellen Randshop Version 2.5 können hier gepostet werden.

Moderatoren: Magnus, mmaass, ablass

Keine E-mails bei Bestellung

Beitragvon hmelk » Fr 16. Aug 2019, 07:45

Hallo,

mit einem Mal bekomme ich keine E-mails mehr bei einer Bestellung und bei einer Testbestellung bekomme ich als Kunde auch keine E-mail mehr.
Wenn ich mit dem Kontaktformular eine E-Mail verschicke, dann kommt sie an.

Hatte von PHP5.6 auf 7.2 umgestellt.
Habe jetzt wieder auf 5.6 umgestellt, aber die Bestell E-Mails kommen trotzdem nicht an.

Hat da wer eine Idee?

Gruß

Hmelk
hmelk
 
Beiträge: 3
Registriert: Mo 28. Jan 2019, 13:50

Re: Keine E-mails bei Bestellung

Beitragvon hmelk » Fr 16. Aug 2019, 07:56

Hallo,

habe nun SMTP deaktiviert und es geht wieder.
Ist zwar super, aber hat wer eine Idee wie ist es dazu gekommen ist?

Gruß

Hmelk
hmelk
 
Beiträge: 3
Registriert: Mo 28. Jan 2019, 13:50

Re: Keine E-mails bei Bestellung

Beitragvon angi » Mi 21. Aug 2019, 13:29

Hallo!

Wir haben ein ähnliches Problem. Es kommen ganz oft keine E-Mails nach Bestellung, allerdings nicht immer. Woran könnte das liegen? Ich habe die LOGs geprüft und es steht dann - bei Fehler - immer "Message body empty" im Mail Log. Das Access Log hilft nicht weiter, dort fehlt einfach der Aufruf der mail_html.php Datei...

Hat jemand eine Ahnung woran es liegen könnte? Wir haben Randshop 2.6 und PHP Version 7.1
Danke für jede Hilfe!

Angelika
angi
 
Beiträge: 4
Registriert: Di 31. Jul 2018, 15:15

Re: Keine E-mails bei Bestellung

Beitragvon ManuelBoesel » Sa 31. Aug 2019, 20:49

Hatten das auch mal, keine Emails vom Shopsystem aber alle anderen über diese Emailadresse gingen.

Es lag daran das der Hoster die Sicherheitseinstellungen bei dem Emailserver erhöht hatte. Er hat dann die Einstellung auf der serverseite wieder gelockert und alles hat wieder funktioniert.

Einfach mal den hoster fragen was er umgestellt hat.
ManuelBoesel
 
Beiträge: 344
Registriert: Sa 2. Feb 2008, 18:29

Re: Keine E-mails bei Bestellung

Beitragvon angi » Mi 4. Sep 2019, 09:19

Es ist ja nicht so, dass gar keine Mails verschickt werden. Meistens klappt alles gut, nur vereinzelt werden Mails nicht gesendet und zwar sowohl die Bestätigungsmails an den Kunden als auch an den Shopbetreiber.
Ich habe versucht die Option "SMTP Mail verwenden" zu benutzen, vielleicht würde das ja helfen. Aber ich schaffe es nicht, auf SMTP umzustellen. Es werden immer noch die Mails über PHP erzeugt: "X-Mailer: PHPMailer 5.2.8".
Was muss ich tun, um SMTP nutzen zu können? Server, Port, Verschlüsselung, Username und PW habe ich eingetragen.

DANKE für jede Unterstützung!
angi
 
Beiträge: 4
Registriert: Di 31. Jul 2018, 15:15


Zurück zu Allgemeines / Installation / Hilfe

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast
cron