Gutscheinmodul funktioniert nicht korrekt

Alle Fragen und Probleme zur aktuellen Randshop Version 2.3 können hier gepostet werden.

Moderatoren: Magnus, mmaass, ablass

Gutscheinmodul funktioniert nicht korrekt

Beitragvon luckyboy100 » Fr 12. Mai 2017, 12:42

Hi,
ich habe das Gutscheinmodul gekauft und wie in der Anleitung beschrieben installiert. Leider kann ich nun unter Aktionscode nur den Kundengutschein auswählen, der Shopgutschein ist nicht auswählbar. Bitte dringend um Hilfe!

Danke
luckyboy100
 
Beiträge: 81
Registriert: Do 17. Jul 2014, 14:39

Re: Gutscheinmodul funktioniert nicht korrekt

Beitragvon mmaass » Mo 15. Mai 2017, 07:35

Hast Du eine 2.5 Version?
Ich habe es soeben in unserer Demo probiert und es klappte Reibungslos.

Wenn Du die Gutscheinaktion speicherst aber noch keine Gutscheine hinterlegt hast, kannst Du dann auswählen?
www.randshop.com
Entwicklung - Anpassung - Support
Benutzeravatar
mmaass
Admin
 
Beiträge: 5168
Registriert: Di 24. Aug 2004, 17:44
Wohnort: Berlin

Re: Gutscheinmodul funktioniert nicht korrekt

Beitragvon pvshop » Fr 29. Jan 2021, 16:32

Ich habe mittlerweile das gleiche Problem.

Ich kann einen Gutschein anlegen, der Aktionstyp ist allerdings ausgegraut (Bild 1). Wenn ich dann Datum und Gutscheintyp fülle und speichere, wird das Dropdown für Änderungen geöffnet und ich kann den Aktionstyp zu "Shopgutschein" ändern. Dann erstelle ich den Gutschein (bei dem dann korrekt die "max. einlösbar" gefüllt wird; Bild 2).
In der Übersicht heißt es allerdings "Anzahl 1" (Bild 3). Und nach einer Einlösung ist dann auch Schluss mit dem Code, egal, wieviele Gutscheine ich erstellt habe.

Wir nutzen 2.6. Ich habe auch schon das Modul neu eingefügt (wobei ich an den Dateien keinerlei Änderungen vorgenomen habe, abgesehen von der Spitzklammer hinter "Aktionstyp", die da nicht hin gehört - das ist aber nur Text. Mit Spitzklammer funktioniertes auch nicht :P ).
Dateianhänge
1.png
Bild 1
1.png (27.62 KiB) 458-mal betrachtet
2.png
Bild 2
2.png (11.72 KiB) 458-mal betrachtet
3.png
Bild 3
3.png (6.58 KiB) 458-mal betrachtet
pvshop
 
Beiträge: 45
Registriert: Di 1. Jul 2014, 06:24

Re: Gutscheinmodul funktioniert nicht korrekt

Beitragvon pvshop » Mo 1. Feb 2021, 10:51

Der Shopgutschein funktioniert doch. :shock: Da jeder Benutzer nur einmal einen Shopgutschein nutzen darf, hat die zweite Einlösung mit meinem Testkäufer natürlich nicht klappen können. :roll: Mein Fehler. :oops:

Dann bleibt aktuell "nur noch" das umständlicher Anlegen, da das Feld anfangs ausgegraut ist. :?:
pvshop
 
Beiträge: 45
Registriert: Di 1. Jul 2014, 06:24

Re: Gutscheinmodul funktioniert nicht korrekt

Beitragvon mmaass » Mo 1. Feb 2021, 14:32

Jup, wollte ich auch gerade schreiben. :)
Das mit der Umständlichkeit müssten wir uns mal anschauen.
www.randshop.com
Entwicklung - Anpassung - Support
Benutzeravatar
mmaass
Admin
 
Beiträge: 5168
Registriert: Di 24. Aug 2004, 17:44
Wohnort: Berlin

Re: Gutscheinmodul funktioniert nicht korrekt

Beitragvon pvshop » Fr 5. Feb 2021, 10:25

Gibt es denn eine Möglichkeit über Änderungen am Modul auch Gutscheine über Versandkosten (dann 100%) zu erstellen? Z.B. über Ergänzungen des Gültigkeitsbereichs?

Das würde uns noch ein paar Verkaufsimpulse mehr ermöglichen.
pvshop
 
Beiträge: 45
Registriert: Di 1. Jul 2014, 06:24

Re: Gutscheinmodul funktioniert nicht korrekt

Beitragvon mmaass » Di 9. Feb 2021, 09:05

Das ist für das Modul so nicht angedacht.
Das kannst Dir gerne individuell anpassen lassen von uns.

Ansonsten schreiben wir es für eine der nächsten Versionen auf. Für die 3.0 geht es nicht mehr, die Baustelle haben wir oft genug wieder geöffnet, jetzt muss die Version auch mal raus. :)
www.randshop.com
Entwicklung - Anpassung - Support
Benutzeravatar
mmaass
Admin
 
Beiträge: 5168
Registriert: Di 24. Aug 2004, 17:44
Wohnort: Berlin

Re: Gutscheinmodul funktioniert nicht korrekt

Beitragvon pvshop » Di 9. Feb 2021, 11:29

OK. Danke. Das habe ich mir schon gedacht.

Welchen Aufwand schätzt Ihr ungefähr dafür? Dann kann ich das mal mit meinem Kollegen besprechen.
pvshop
 
Beiträge: 45
Registriert: Di 1. Jul 2014, 06:24

Re: Gutscheinmodul funktioniert nicht korrekt

Beitragvon mmaass » Do 18. Feb 2021, 13:14

Das kann ich leider so nicht wirklich sagen.
Das müssen wir uns erst anschauen. Es kann 1-2 Stunden dauern, jedoch wenn sich da mehrere andere Schrauben mit drehen, kann es auch 4h oder länger dauern. Die Komplexität des Systems lässt kaum noch einfache Änderungen zu. :)
www.randshop.com
Entwicklung - Anpassung - Support
Benutzeravatar
mmaass
Admin
 
Beiträge: 5168
Registriert: Di 24. Aug 2004, 17:44
Wohnort: Berlin


Zurück zu Allgemeines / Installation / Hilfe

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 5 Gäste